banner

AfterPay Status Page

Nordics: MyAfterPay.com users may experience problems with logging to the customer portal
Incident Report for AfterPay
Resolved
The issue has been resolved.
Posted Nov 26, 2021 - 11:13 CET
Identified
Unfortunately, we have to inform you about an ongoing incident with our external service provider that is disrupting our service.
The service has been affected since 9.12 am CET.

They are working hard to solve the issues.
We will provide you with an update within 1 hour.
Posted Nov 26, 2021 - 09:48 CET
This incident affected: MyAfterPay & App (MyAfterPay).